Image Editing
This quick reference is for GIMP 2.8
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Quick Reference

Certification Test Goals

i B - 1 This module sets out essential concepts and skills relating to the
1= Layers ability to understand the main concepts underlying digital images and
15 ¢ Channels, to use an image editing application to enhance images, apply effects,
q=n [ Paths, Undo and prepare an image for printing and publishing.
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o 3 « Know about the main concepts of using digital images and
ae understand graphic format options and colour concepts.
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HIPAS - Tool Options set image file options.
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a N « Use built-in options such as displaying toolbars, palettes to
[ et enhance productivity.
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=1 . « Capture and save an image, use various selection tools, and
b manipulate images.

. 7 « Create and use layers, work with text, use effects and filters, and
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[Fre— * Prepare images for printing or publishing.
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1 Imaging Concepts

1.1
111

1.1.2

1.1.2

113

Digital Images
Identify common uses of digital images
like:
* Web and print publishing - Publish
images to websites, social networks
or photo sharing sites, or use for print
publishing (magazines, brochures)
« Distribution by e-mail and mobile phone -
Send your images to friends, colleagues
* Home printing - Use a printer, photo
printer
« Digital photo frames - Display images on
a digital photo frame

Understand the terms pixel, resolution.

« Pixel - the smallest part of a digital image
on a screen or a single point in a raster
image

» Resolution - the measure of the detail
quality of a digital image

Identify the key features of a digital image:
« Composed of discrete pixels
» Represented digitally in binary code

Understand the terms lossy, lossless image
file compression.

* Lossy compression creates a smaller
sized compressed file that results in a
lower resolution picture with pixel loss.

* Lossless compression ensures that the
compressed data can be reconstructed
to the exact original image without pixel
loss.

1.1.4

1.1.4

1.2
1.21

1.21

Understand the term copyright and the
implications for image use.
» Copyright - the rights granted to use, publish
or distribute images, or other pieces of work
for a specific time period

Understand the terms royalty-free images and
rights-managed images.

* Royalty-free images incur a one-off fee that
allows the user to use the image as many
times as required with some restrictions.

+ Rights-managed images have a copyright
license which, if purchased by a user, allows
the one-time use of a photo as specified by
the license.

Graphic Formats
Understand the terms raster and vector
graphics and distinguish between them.

» Raster graphics - represent a grid of pixels
and cannot be scaled to a larger size without
losing quality

» \ector graphics - created using points, lines
and curves, based on mathematical equations
and can be scaled to a large size without
losing quality

Identify common raster (jpeg, gif) and vector
(svg, eps) formats.

Raster File Format File Extension

Joint Photographic Experts Group .ipeg
(JPEG)
Graphics Interchange Format (GIF) .gif

1.3
1.3.1

1.3.1

132

Vector File Format File Extension

Scalable Vector Graphics (SVG) .svg
Encapsulated PostScript (EPS) .eps

Recognize proprietary digital image editing
application formats:

File Format File Extension

Photoshop Native Format .psd
Paint Shop Pro Native Format .psp
GIMP Native Format xcf
Corel Photo-Paint Format .cpt

Colour Concepts
Understand the term colour model.

* A mathematical model describing how
colours can be represented as lists of
numbers, typically as three or four values
or colour components.

Recognize common colour models:

* RGB - Combines red, green and blue

* HSB - Combines hue, saturation and
brightness

+ CMYK - Combines cyan, magenta, yellow
and key (black)

» Grayscale - Combines shades of gray,
varying from black to white

Understand the terms colour palette,
colour depth.
+ Colour palette - the total colours available
» Colour depth - the maximum number of
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2 Image Capture

3 Using the Application

distinct colours that are used in an image,
higher depth gives a broader range of
distinct colours and a more realistic
image

132 Understand the terms hue, saturation,
colour balance.

* Hue - A pure colour described by name
like red or yellow

« Saturation - The dominance of hue in the
colour

« Colour balance - The overall adjustment
of the intensities of the colours

1.32 Understand the terms contrast, brightness,
gamma.

» Contrast - The difference in colour and
light level in an image

« Brightness - The degree to which an
image radiates light

* Gamma - The way brightness is changed
for the middle range of gray tones

132 Understand the term transparency.
« Transparency - The ability of light to
transmit through an image

2.1 Capturing Images
21.1 Save an image from a digital camera to a
location on a drive.
« Connect the digital camera to the
computer.
« Follow the Wizard instructions to choose
the image to save.
» Select the location on the drive and save
the image.

21.2 Use the print screen facility to capture a full
screen.
* Press the Print Screen key.
« Open an image editing application.
« Click the Edit menu.
« Click Paste.

21.2 Use the print screen facility to capture an
active window.
* Open a window on the desktop.
« Press the Alt key + Print Screen key on
the keyboard.
« Open an image editing application.
« Click the Edit menu.
« Click Paste.

213 Save an image from an image library, web
page to a location on a drive
« Right-click the image.
» Select Save image as.
« Create a file name and navigate to the
location required.
» Click Save.

214 Open a scanning application and scan an
image: preview, set scanning parameters,
scan, save.

« Place the image on the scanner.

« Click scan to view options.

» Follow the instructions to choose the
scanning parameters.

« Navigate to the location required to save
the image and scan.

3.1 Image Creation

311 Open an image editing application.
« Click the Start button.
« Select All Programs.
+ Click GIMP2.

31.1  Close an image editing application.
* On the File menu, click Quit.

311 Open image files.
* On the File menu, click Open.
» Select file(s) to open and click Open.

311 Close image files.
* On the File menu, click Close to close
the current image window or Close all to
close all opened images.

312 Create a new image file and set options:
colour model, size, resolution, background
colour.

+ On the File menu, click New.

®

+ Set the file options.
+ Click OK.

313 Create a new image file from clipboard.
« Ensure an item has been copied to the
clipboard.
* On the File menu, select Create.
* Click From Clipboard.

3.1.4 Switch between open image files.

I:l Image Twoscf-3
I:l Image Onexcf-1
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* On the Windows menu, select Dockable
Dialogs.

+ Click Images.

» Click the image file required from the Images
dialog to switch to that file.

315 Save an image to a location on a drive.
« On the File menu, click Save.
+ Create a file name and navigate to the
required location.
» Click Save.

315 Save an image under another name to a
location on a drive.
* On the File menu, click Save As.
» Enter a new file name over the existing file
name and navigate to the location required.
* Click Save.

3.1.6 Save, export an image as another file type like:
ipeg, gif, tiff, png.
» On the File menu, click Export.
» Click the Select File Type (By Extension) drop-
down menu and click a file type.
* Click Export.

3.2 Settings
321 Set background colour, foreground colour.
* In the Toolbox, click the Set Background
Color or Set Foreground Color option.
» Select the colour required.
+ Click OK.

322 Set grid properties: units, horizontal spacing,
vertical spacing, colour.
« On the Edit menu, click Preferences.
* Click Default Grid.
+ Click the Line style, Foreground color and
Background color required.
» Enter the spacing and offset required.
+ Click OK.

3.3 Enhancing Productivity
331 Set basic options/ preferences in the
application like: transparency, grid settings,
measurement units.
» To set transparency, on the Edit menu, click
Preferences.
» Click Display.
+ Click the transparency Check style and Check
size required.

» Click OK.
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3.3.2

3.3.3

3.34

3.34

3.35

» To set grid settings, on the Edit menu,
click Preferences.

+ Click Default Grid.

+ Click the grid Line style, Foreground color
and Background color.

» Enter the gridline spacing and offset
required.

+ Click OK.

» To set measurement units, on the Edit
menu, click Units.

+ Check the checkboxes for the Units
required.

* Click Close.

Use available Help functions.
* On the Help menu, click Help.

Use magnification/zoom tools.
* On the View menu, select Zoom (100%)
and click Zoom Out or Zoom In.

Use the undo, redo command.
« On the Edit menu, click Undo or Redo.

Use the undo history.
+ On the Edit menu, click Undo History.
+ Select a state in the file history to revert to.

Display, hide built-in toolbars, palettes,
windows.
«  On the Window menu, select/deselect
appropriate toolbar, palette, window.

Windows | Help
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4 Working with Images

4.1
4.1.1

4.1.2

Selection
Select an entire image, layer(s).
+ To select an entire image, on the Select
menu, click All.
» To select a layer, in the Layers panel, click
the layer required.

Set selection tool properties: relationship
between multiple selections, feathering,
antialiasing, width, height.

* In the Toolbox, click the required
Selection Tool, choosing from the
Rectangle, Ellipse, Free, Fuzzy, Select by
color, Scissors Select Tool.

+ In the Tool Options, select the required
relationship between selections option.

» Check the feathering and antialiasing
check boxes and enter the width and
height required.
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413

4.1.4

4.1.5

4.1.5

4.2
4.2

423

424

424

Select part of an image using selection
tools: rectangular, elliptic, magic wand,
magnetic lasso, freehand image.

Rectangle / Draws square or rectangular
Ellipse select selection borders or draws round or
tool elliptical selection borders.

Fuzzy select tool
(Magic Wand)

Selects pixels of similar colour with
one click.

Scissors select Draws a selection border using
tool intelligent edge fitting.

Draws freehand selection borders.
This tool is great for making very
precise selections.

Free select tool
(Lasso)

* In the Toolbox, click the required
Selection Tool.
« Select a part of the image using the tool.

Inverse a selection.
< In the Toolbox, click the required
Selection Tool.
» Select a part of the image using the tool.
« On the Select menu, click Invert.

Save a selection.
« In the Toolbox, click the required
Selection Tool.
» Select a part of the image using the tool.
* On the Select menu, click Save to
Channel. Enter a Selection Name.
« Click OK.

Load a saved selection
« In the Channels panel, choose the
required selection.
» Click the red square icon to load the
selection.

Channels - Brushes =k
EGIMP Quick Reference Guideaxcf-1
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Image Manipulation

Change the canvas size of an image.
* On the Image menu, click Canvas Size.
« Enter the width and height required.
« Click Resize.

Resize an image in pixels, measurement
units.
« On the Image menu, click Scale Image.
» Enter the width and height required.
» Select the required measurement unit.
« Click Scale.

Crop an image.
« In the Toolbox, click the Crop Tool.
» Click and drag to select the part of the
image you wish to crop using the tool.
» Press the Return key to accept changes.

Copy image(s), selection within an image.
< In the Toolbox, click the Move Tool.
* Select the image and click Ctrl + C to
copy.
« Paste the image selection into the desired
location.

Move image(s), selection within an image.
* In the Toolbox, click the Move Tool.
» Select the image and click and drag to
move.

425

4.3
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4.3.4

4.3.4

4.3.4
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Rotate, mirror an image, selection within an
image.
* In the Toolbox, click the required Selection
Tool.
+ Select the image, part of image you wish to
rotate, mirror.
* On the Image menu, click Transform and click
the required rotation or flip (mirror) option.

Layers
Define and understand the term layer.
» Layers are used to separate different
elements of an image and are stacked on top
of each other.

Create a layer.
* On the Layer menu, click New Layer.

* Enter the Layer Name, Width, Height required.

» Check the Layer Fill Type check box required.
» Click OK.
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Copy a layer.
* In the Layers panel, select the layer to copy.
* On the Layer menu, click Duplicate Layer.
» Edit a new layer name in the Layers dialog.

Delete a layer.
* In the Layers panel, select the layer to delete.
* On the Layer menu, click Delete Layer.

Set layer properties: name.

=
€l

Mede: Normal E
= =
Lok g B

@ [Pl rorererioe
o e
S s [

ODbE &« 4 & & @

* In the Layers panel, double-click the layer to
open layer properties.

« Edit the Layer Name.

+ Click OK.

Set layer properties: hide, show.
* In the Layers panel, click the Eye symbol to
Show/Hide a layer.

Set layer properties: lock.
* In the Layers panel, click to the right of Lock
to Lock pixels or Lock alpha channel.

Set layer properties: opacity.
* In the Layers panel, adjust the Opacity slider
to select the appropriate opacity.

Set layer properties: blending mode.
* Inthe Layers panel, click the Mode drop-
down arrow.
» Select the appropriate blending mode.

Arrange layers.
* On the Layer menu, click Stack.
» Select the appropriate option to Raise / Lower
the layer.

Merge layers.
* Inthe Layers panel, select the layer to merge.
» On the Layer menu, click Merge Down to
merge to the layer below.

Link layers.
* In the Layers Panel, click to the right of the
Eye symbol on appropriate layers to link these
layers.

434

435

435

435

4.3.5

435

4.3.6

4.3.7

4.4
4.4.1

4.4.1

4.4.1

Flatten layers.
* On the Image menu, click Flatten Image
to merge all layers into one.

Transform layer(s): scale.
» Select the layer to transform.
+ On the Layer menu, click Scale Layer.
+ Enter the desired Layer Size and Quality.
+ Click Scale.

Transform layer(s): rotate.
+ Select the layer to transform.
* On the Layer menu, click Transform
and select the appropriate layer rotation
option.

Transform layer(s): flip.
+ Select the layer to transform.
* On the Layer menu, click Transform and
select the appropriate layer flip option.

Transform layer(s): move.
» Inthe Layers panel, select the layer to
move.
+ Click the Move Tool, click and drag the
layer to the required location.

Transform layer(s): trim.
* On the Layer menu, click Layer Boundary
Size.
* In the Toolbox, click the Crop Tool.
+ Enter the required Layer Size and Offset.
+ Click Resize.

Convert a drawn object to a raster layer.
+ Select a text layer.
» On the Layer menu, click Discard Text
Information.
Note: Only text layers can be converted to
a raster layer in GIMP.

Create an animated gif from layers.
» On the File menu, click Export.
+ Create a file name and navigate to the
location required.
+ Select GIF image as the file type.

&) Bxport Image a3 GIF =
GIF Options
[] Interlace
GIF comment:

Created with GIMP

As animation

Animated GIF Options
Loop forever

Delay between frames wher : poo 3
Frame disposal where unspecified: |1 don't care -
[ Use delay entered above for all frames

[7] Use disposal entered above for all frames

+ Check the As animation GIF Option
checkbox and select any additional loop
and frame delay settings.

» Click Export.

» Click Save.

Note: You must have two or more layers to
create an animated gif.

Text
Add text.
* In the Toolbox, click the Text Tool.
+ Click and drag on the image to create a
text editing region.
» On the Options bar, select text options
and enter text.
+ Click outside the text editing region to
accept changes.

Edit text.
* In the Toolbox, click the Text Tool.
» Double-click on existing text to open the
text editing region.
+ Edit the text as required.
+ Click outside the text editing region to
accept changes.

Delete text.
* In the Toolbox, click the Text Tool.
» Double-click on existing text to open the
text editing region.
» Delete the text as required.
+ Click outside the text editing region to
accept changes.
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4.4.2 Copy, move text.
In the Toolbox, click the Text Tool.
» Double-click on existing text to open the
text editing region.
* Select the text to copy, move.
* On the Edit menu, click Cut or Copy.
« Paste the text into the desired location.

443 Align text: left, centre, right, justified.
* In the Toolbox, click the Text Tool.
» Double-click on existing text to open the
text editing region.
* Select the text to align.
* In the Tool Options, select the desired
justify alignment.

444 Apply text formatting: font sizes, font types,

font colour.

* In the Toolbox, click the Text Tool.

« Double-click on existing text to open the
text editing region.

« Select the text to format.

* On the Options bar, select the desired
font size, font type or font colour.

» Click OK to accept font colour changes.

445 Apply a text warp.
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* In the Toolbox, click the Text Tool.

» Double-click on existing text to open the
text editing region.

» Select the text to text warp.

* On the Filters menu, click Distorts and
Curve Bend.

» Select the desired Curve and adjust
settings for Border, Type and Rotate.

« Click OK.

4.5 Effects and Filters
451 Apply artistic, distortion effects: pixelate,
emboss, wind, ripple, twirl, desaturate.
« Select the image, part of image using a
Select Tool from the Toolbox.
< To apply a pixelate effect, on the Filters
menu, select Blur and click Pixelize.
« To apply an emboss effect, on the Filters
menu, select Distorts and click Emboss.
« To apply a wind effect, on the Filters
menu, select Distorts and click Wind.
« To apply aripple effect, on the Filters
menu, select Distorts and click Ripple.
« To apply a twirl effect, on the Filters
menu, select Distorts and click Whirl and
Pinch.
« To apply a desaturate effect, on the
Colors menu, click Desaturate.
« Adjust the settings as required.
« Click OK.

452 Apply blur effects: gaussian, motion.

« Select the image, part of image using a
Select Tool from the Toolbox.

« To apply a Gaussian blur effect, on
the Filters menu, select Blur and click
Gaussian Blur.

« To apply a motion blur, on the Filters
menu, select Blur and click Motion Blur.

« Adjust the settings as required.

« Click OK.

453 Apply lighting effects: lighting, flare.
Select the image, part of image using a
Select Tool from the Toolbox.

« To apply a lighting effect, on the Filters
menu, select Light and Shadow and click
Lighting Effects.

« To apply a flare effect, on the Filters
menu, select Light and Shadow and click
Lens Flare.

« Adjust the settings as required.

« Click OK.

454

4.5.5

4.5.5

4.5.6
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Apply adjustments: brightness-contrast, hue-
saturation, colour balance.
» Select the image, part of image using a Select
Tool from the Toolbox.
» To adjust brightness-contrast, on the Colors
menu, click Brightness-Contrast.
» To adjust hue-saturation, on the Colors menu,
click Adjust Hue-Saturation.
» To adjust colour balance, on the Colors menu,
click Color Balance.
» Adjust the settings as required.
+ Click OK.

Apply sharpen mask.
Select the image, part of image using a Select
Tool from the Toolbox.
* On the Filters menu, select Enhance and click
Sharpen.
» Adjust the settings as required.
+ Click OK.

Apply unsharpen mask.
« On the Filters menu, select Enhance and click
Unsharp Mask.
» Adjust the settings as required.
» Click OK.

Apply red eye reduction.
Select the image, part of image using a Select
Tool from the Toolbox.
« On the Filters menu, select Enhance and click
Red Eye Removal.
» Adjust the settings as required.
» Click OK.

5.2.6

Clone a portion of an image using a clone
tool, selecting size, opacity.
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* In the Toolbox, click the Clone Tool.

+ In the Tool Options, click the Opacity,
Brush and Size required, and adjust other
settings as required.

+ Hold the Ctrl key and make your clone
selection.

+ Click the required location to place the
cloned content.

5 Drawing and Painting 6 Prepare Outputs

5.1
Bl

5.1.2

5.2
5.2.1

522

5.2.3

5.2.4

525

Drawing Tools
Add a line to an image: straight line, free drawn
line, curves. Set, modify line weight, style and
colour.
« In the Toolbox, click the Paintbrush Tool or
Pencil Tool.
* In the Tool Options, select the desired Brush,
Size, Aspect Ratio and Angle.
* Draw the line.

Add a shape to an image: rectangle, ellipse,n-
shaped polygon. Set, modify line, fill style and
colour.

* In the Toolbox, click the Rectangle Select
Tool, Free Select Tool or Ellipse Select Tool.

* Draw the shape using the select tool.

» To create a filled shape, in the Toolbox,
choose a foreground color and fill the
selection with the Bucket Fill Tool.

» To create an outline shape, on the Edit menu,
click Stroke Selection.

» Adjust the settings as required and click
Stroke.

Painting Tools
Pick up a colour value with the dropper.
* In the Toolbox, click the Color Picker Tool.
» Select the colour of the image to pick and
click that colour to select.

Fill a portion of an image with the gradient tool,
selecting opacity/transparency, radial, linear,
position, rotation.
* In the Toolbox, click the Blend Tool.
* In the Tool Options, click the required Opacity,
Gradient, Shape, Repeat and Offset.
+ Click the gradient start location and drag to a
finish location to apply the gradient.

Colour a portion of an image with the
palntbrush tool, selecting colour, shape, size.
In the Toolbox, click the Paintbrush Tool and
click a Foreground Color.
* In the Tool Options, click the Brush and Size
required.
» Colour the portion of the image.

Erase a portion of an image with the eraser
tool, selecting its shape and size.
« In the Toolbox, click the Eraser Tool.
* In the Tool Options, click the Brush and Size
required.
» Erase the portion of the image.

Fill a portion of an image with colour using the
paint bucket tool.

* In the Toolbox, click the Bucket Fill Tool.

» Click a Foreground Color.

« Fill the portion of the image with the colour.

6.1
6.1.1

6.1.2

6.2
6.2.1

6.2.1

Setup
Preview an image.
« On the File menu, click Print.
+ Click the Image Settings tab to view the
print preview.

Select appropriate colour depth, resolution,
image size, graphic format for web, screen,
print use.
» To adjust colour depth, on the Image
menu, click Mode.
+ Click the colour depth mode required. @
+ To adjust resolution or image size, on the
Image menu, click Scale Image.
» Click the resolution or image size
required.
» To adjust graphic format, on the File
menu, click Export.
» Click the graphic format required.
» Click Export.

Print
Change print output orientation: portrait,
landscape.
* On the File menu, click Print.
« On the General tab, click Preferences.
* Under Orientation, click Portrait or
Landscape.
+ Click OK.

Change paper size.
* On the File menu, click Print.
* On the General tab, click Preferences.
» Under Paper sizes, click the paper size
required.
» Click OK.

Print an image to an installed printer using
defined options, default settings.
* On the File menu, click Print.
+ Select additional print options if required.
+ Click Print.

For more information,
visit: www.ecdl.org
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